Monica's Blog

Just another WordPress.com site

Eliminarea unor cifre in baza 10

1.Exemplu:

Se da un numar natural n. Sa se elimine din numar cifrele prime.

n c p m
835476 1 0
6 10 6
7
4 100 46
5
3
8 1000 846

2.Pseudocod:

Start

citeste n

p=1

m=0

cat timp n!=0 executa c=n%10

n=n/10

Daca c!=2 && c!=3 && c!=5 && c!=7 atunci m=m+c*p

p=p*10

scrie m

Stop

m=m+c*p

p=p*10

Min, Max

1.Exelmplu:

Se da un numar natural n care apartine N.Sa se afiseze cea mai mare cifra a numarului

Start

citeste n

max=0

cat timp n!=0 executa c=n%10

n=n/10

Daca c>max atunci max=c

scrie max

stop

Oglinditul unui numar

Exemplu:

Se da un numar  n care apartine N.Se cere sa  se afiseze oglinditul numarului.

n c ogl
1472 2 0
147 7 2
14 4 27
1 1 274
0 0 2741

2.Pseudocod

start

citeste n

og=0

cat timp n!=0 executa c=n%10

n=n/10

og=og*10+c

scrie og

stop

Og=Og*10+c

Cifrele unui numar

a)Enunt

Se da un numar natural n. Se cere sa se afiseze cifrele numarului.

b) Exemplu:

n c
1472 2
147 7
14 4
1 1
0 0

 

c)Algoritmul:

-se citeste n;

-cat timp n!=0  executa

-aflam ultima cifra(c=n%10)

-eliminam ultima cifra(n=n/10)
-afisam cifra(C);

d)Pseudocod:

start

citeste n;

cat timp n!=0 executa c=n%10

n=n/10

scrie c

stop

e)OBS:

1.Numarul n se modifica

2.Cifrele numarului se afla in ordine inversa: intai cifra unitatilor, cifra zecilor, cifra sutelor, cifra miilor….;

 

Cmmmc

1.Exemplu:

x y a b
20 35 20 35
40 35    
40 70    
60 70    
80 70    
80 105    
100 105    
120 105    
120 140    
140 140    

2.Pseudocod:

start

citeste a,b

x=a

y=b

cat timp x!=y executa

Daca x<y atunci x=x+a

altfel y=y+b

scrie x

stop

Top 10 Music Hits-Bilboard

Catelul meu

 

Euclid

Algoritmul lui Euclid pentru determinarea cmmdc

1.Enunt

Sa se calculeze cmmmdc a 2 numere

2.Exemplu :

a b r
50 78 50
78 50 28
50 28 22
28 22 6
22 6 4
6 4 2
4 2 0

3.Algoritm:

-citim a,b;

-calculam restul r=a%b;

-cat timp restul este diferit de zero executa a=b,b=r,r=a%b;

-afiseaza b;

4.Pseudocodul

Start

citeste a,b

r=a%b

cat timp r!=0 executa

a=b

b=r

r=a%b

scrie b

stop

5.OBS

a) In urma caclularii cmmdc-ului numerele se modifica si pentru a le folosi apoi trebuie sa le facem o copie.

b)Agoritmul lui Euclid este mai rapid decat algoritmul prin scaderi repetate, pentru ca foloseste impartiri.

Cmmdc

Cel mai mare divizor comun

1.Enunt:

Se dau 2 numere.Se cere sa se determine cel mai mare divisor comun al lor.

2.Ex:

A B
90 42
48 42
6 42
6 36
6 30
6 24
6 18
6 12
6 6

Cmmdc(90,42)=6

Cmmdc(90,0)=90

Cmmdc(0,80)=80

a=0 =>cmmdc=b

b=0 =>cmmdc=a

a*b=0 => cmmdc=a+b

3.Algoritm:

-citim a,b;

-daca a*b=0 scrie a+b, altfel cat timp a!=b executa daca a>b atunci din a scadem pe b, altfel din b scadem pe a;

4.Pseudocod:

Start

Citeste a,b

Daca a*b=0 atunci scrie a+b

Altfel cat timp a!=b executa daca a>b atunci a=a-b

altfel b=b-a

scrie a

stop

5.OBS:

a) Numerele se modifica.Daca vrem sa le pastram gtrebuie sa le facem o copie(x=a;y=b)

b)Algoritmul este lent din punct de vedere al timpului.

Trupa romaneasca preferata

 

Global Battle Of The Bands este cel mai mare concurs de muzica live din lume, iar acum peste treizeci de trupe romanesti concureaza pentru un loc in finala GBOB, care se desfasoara 26 Februarie 2011 la Kuala Lumpur in Malaesia.

Etapa din Romania se va desfasura pe parcursul a trei zile, doua pentru semifinale si una pentru finala, pe 26, 27 si 28 Noiembrie, intr-un cort incalzit la Arenele Romane din Bucuresti, unde intrarea este gratuita, asa ca poti merge acolo pentru a-ti sustine trupa.

In cazul in care nu reusesti sa ajungi la eveniment, ramai pe MTV.ro pentru a afla care sunt trupele care intra in semifinale si, mai apoi, in finala si pentru a urmari LIVE prestatia lor de la Arenele Romane.

Trupa care castiga competitia din Romania se va lupta apoi pentru titlul de „Best New Band in The World 2010” si un premiu de 100.000 USD.

Daca ai o trupa si vrei sa intri in competitie, inscrie-te aici!

VOTEAZA-TI PREFERATII AICI!

Evenimentul este organizat in Romania de Sfinx Experience si sustinut de Consiliului General al Primariei Municipiului Bucuresti, ARCUB, Centrul Cultural pentru UNESCO Nicolae Balcescu si Primaria Sectorului 4.